SHEsis with Permutation User Guide

Main Page

Content

  • System requirement and installation
  • Input format
  • Parameter settings
  • View results

    • Contact us

    E-mail author(agathah@163.com) | SHEsis mainpage


System requirement and installation

Before run this program, make sure that you have installed Java Runtime Environment. We provide link to Sun's latest version of JRE in our download page.

After download the *.RAR file, what you need to do is only to uncompact it. There would be two folders named "img" and "bin", an excutable jar file named "Permutation" in your path. Run "Permutation", please don't move or rename any of the folders or files. Illustration1 shows the program GUI.

The core of SHEsis program is coded by C++ while GUI is coded by Java. We develop and test it under Windows environment, so it is recommended not to run this program under Linux or MacOS, as unexpected result may occur. Also, our test data may not cover all aspects. If some bugs appear during running, please send us your origin data, the program parameters and the error code.

Main page

Contact us

E-mail author(agathah@163.com) | SHEsis mainpage


Input format

You can paste the data from clipboard, or you can open a saved *.txt file from disk.

The format of input data should be like this:

ID1 G A 1 1 a b ...
ID2 A G 1 2 b b ...
ID3 G G 1 1 c c ...
......

Here, the first column refers to the sample ID; the second and third column refer to the alleles of the 1st site; fourth & fifth for the 2nd site; sixth & seventh for the 3rd site; etc. Please use "0" for the missing alleles; space or tab is used to split each column. It is worked if you use multiple space or tab, or even mix them together, but we don't recommend such input data. If your input is illegal, the program would show a warning dialog and break the later process.

Contact us

E-mail author(agathah@163.com) | SHEsis mainpage


Parameter settings

First choose the analysis you need, default selection is Allele and Genotype only. You must input the number of sites and number of permutation. Make sure the site number agrees with your input data. Default number of permutation is 100. Of course the bigger the number is, the more accurate the result is, and the more time it would take to process.

If you selected the haplotype analysis, you should assign the lowest frequency threshold(LFT). Haplotypes whose frequency is lower than LFT would not be calculated during process. Default value is 0.03.

Mask of haplotype helps you to select sites for haplotype analysis. "0 1 1 1 0" is a valid mask; it select the 2nd, 3th, 4th sites for hap-analysis while there are five sites in total. Default mask(all 1) is generated automatically right after your input of site number. Use space or tab to split each element of the mask: "0" means neglect. If your input is invalid, we just assum it as the default mask.

If you select the "Pair-loci D'/r2 value", you can assign where to calculate the linkage disequilibrium: Both case and control data, or case data only, or control data only.

Your input is checked. Invalid input would break the later progress and show a warning dialog. Check the information and try again.

Contact us

E-mail author(agathah@163.com) | SHEsis mainpage


View results

  • Allele and genotype analysis
  • Pair-loci D'/r2 value
  • Haplotype analysis

    • Main page

    Contact us

    E-mail author(agathah@163.com) | SHEsis mainpage


System requirement and installation

SHEsis with Permutation User Guide

Single-site analysis

If you selected "Allele and genotype" analysis, these parts would be included in the result. Output format refers to our online version, so there would be no trouble understanding each parts' meaning..

If you assigned site names, such names as "Site1" would be replaced by your specific site names.

Single site tests:
-------------------------------
Sites1(Allele)
    A(freq)	G(freq)
Case:	557(0.6162)	347(0.3838)
Control:531(0.5848)	377(0.4152)
Odds Ratio=1.1397	 95% CI=[0.9442~1.3755]
Chi2 is 1.8556 while df=1
Fisher's p value is 0.1732
Pearson's p value is0.1731
Permutation p value(Fisher) is 0.9900
Permutation p value(Pearson) is 0.9900
-------------------------------
Sites1(Genotype)
    A A(freq)	G G(freq)	A G(freq)
Case:	169(0.3739)	64(0.1416)	219(0.4845)
Control:149(0.3282)	72(0.1586)	233(0.5132)
Chi2 is 2.1577 while df=2
Fisher's p value is 0.3401
Pearson's p value is 0.3400
Permutation p value(Fisher) is 1.0000
Permutation p value(Pearson) is 1.0000
===============================
Sites2(Allele)
......etc.

View results

Contact us

E-mail author(agathah@163.com) | SHEsis mainpage


System requirement and installation

SHEsis with Permutation User Guide

Pair-loci D'/r2 value

If you selected "Pair-loci D'/r2 value" analysis, these parts would be included in the result.

If you assigned site names, such names as "Site1" would be replaced by your specific site names.

D'
    Sites1	Sites2	Sites3	Sites4	Sites5	Sites6
Sites1	-	0.645	0.886	0.892	0.655	0.712
Sites2	-	-	0.000	0.865	0.781	0.901
Sites3	-	-	-	0.891	0.791	0.829
Sites4	-	-	-	-	0.850	0.916
Sites5	-	-	-	-	-	0.891
Sites6	-	-	-	-	-	-

If you assigned site names, such names as "Site1" would be replaced by your specific site names.

r2
    Sites1	Sites2	Sites3	Sites4	Sites5	Sites6
Sites1	-	0.220	0.330	0.365	0.278	0.251
Sites2	-	-	0.000	0.640	0.499	0.754
Sites3	-	-	-	0.747	0.404	0.602
Sites4	-	-	-	-	0.513	0.761
Sites5	-	-	-	-	-	0.609
Sites6	-	-	-	-	-	-

View results

Contact us

E-mail author(agathah@163.com) | SHEsis mainpage


System requirement and installation

SHEsis with Permutation User Guide

Haplotype analysis

If you selected "Haplotype" analysis, this part would be included in the result.t.

If you assigned site names, such names as "Site1" would be replaced by your specific site names.

Haplotype analysis
(All those frequency<0.03 will be ignored in analysis.)
Loci chosen for hap-analysis:Sites1 Sites2 Sites3 Sites4 Sites5 Sites6
        freq(case)	freq(ctrl)	chi2	Fisher's p	Pearson's pMonteCarlo p(Fisher)	MonteCarlo p(Pearson)	Odds Ratio [95%CI]
A A A G G A 	-	-	-	-	-	-	-	-	-	-
A A G G C A *	0.0596	0.0244	12.2468	0.0005	0.0005	0.0100	0.0100	2.5789 [1.4907,4.4615]
A A G G C G *	0.1864	0.1890	0.0020	0.9648	0.9647	1.0000	1.0000	0.9942 [0.7664,1.2895]
A A G G G A *	0.2119	0.2657	6.0221	0.0142	0.0141	0.4000	0.4000	0.7398 [0.5813,0.9415]
A A G G G G *	0.0693	0.0143	29.5768	0.0000	0.0000	<0.0100	<0.0100	5.2209 [2.7031,10.0840]
A G A A C A 	-	-	-	-	-	-	-	-	-	-
A G A A C G 	-	-	-	-	-	-	-	-	-	-
A G A A G A 	-	-	-	-	-	-	-	-	-	-
A G A A G G 	-	-	-	-	-	-	-	-	-	-
A G A G C A 	-	-	-	-	-	-	-	-	-	-
A G A G C G *	0.0124	0.0333	7.4632	0.0063	0.0063	0.2600	0.2600	0.3677 [0.1744,0.7753]
A G A G G A 	-	-	-	-	-	-	-	-	-	-
A G A G G G 	-	-	-	-	-	-	-	-	-	-
A G G G C A 	-	-	-	-	-	-	-	-	-	-
A G G G C G 	-	-	-	-	-	-	-	-	-	-
A G G G G A 	-	-	-	-	-	-	-	-	-	-
A G G G G G 	-	-	-	-	-	-	-	-	-	-
G A G G C G 	-	-	-	-	-	-	-	-	-	-
G A G G G G 	-	-	-	-	-	-	-	-	-	-
G G A A C A *	0.0292	0.0343	0.3002	0.5838	0.5838	1.0000	1.0000	0.8526 [0.4816,1.5092]
G G A A C G *	0.1292	0.1367	0.1383	0.7100	0.7100	1.0000	1.0000	0.9452 [0.7022,1.2723]
G G A A G A *	0.1534	0.1614	0.1320	0.7164	0.7164	1.0000	1.0000	0.9498 [0.7193,1.2541]
G G A A G G 	-	-	-	-	-	-	-	-	-	-
G G A G C G 	-	-	-	-	-	-	-	-	-	-
G G A G G A 	-	-	-	-	-	-	-	-	-	-
G G A G G G 	-	-	-	-	-	-	-	-	-	-
A A A G G G 	-	-	-	-	-	-	-	-	-	-
A A G A G A 	-	-	-	-	-	-	-	-	-	-
G A A A C A 	-	-	-	-	-	-	-	-	-	-
G A A A C G 	-	-	-	-	-	-	-	-	-	-
G A A A G A 	-	-	-	-	-	-	-	-	-	-
G A A A G G 	-	-	-	-	-	-	-	-	-	-
G A G G C A 	-	-	-	-	-	-	-	-	-	-
G G A G C A 	-	-	-	-	-	-	-	-	-	-
G G G A C G 	-	-	-	-	-	-	-	-	-	-
G G G A G G 	-	-	-	-	-	-	-	-	-	-
G G G G C G 	-	-	-	-	-	-	-	-	-	-
G G G G G A 	-	-	-	-	-	-	-	-	-	-
Global result:
Total case=774, total control=751
Global chi2 is 51.8818 while df=7 (frequency<0.03 in both control & case has been dropped.)
Fisher's p value is 0.0000
Pearson's p value is 0.0000
Permutation p value(Fisher) is 0.0000
Permutation p value(Pearson) is 0.0000

View results

Contact us

E-mail author(agathah@163.com) | SHEsis mainpage